Banner 7
Navigation & Overview

October 17, 2006
Table of Contents

Chapter 1: Overview........................................................................................................ 4
Purpose/Audience: ........................................................................................................ 4
Module Leaders ....................................................................................................... 4
Introduction: ................................................................................................................. 5
Starting Banner: ........................................................................................................... 5
Display ........................................................................................................................ 5
Accessing INB .......................................................................................................... 6
Creating a Shortcut .................................................................................................. 6
Login ........................................................................................................................ 7

Chapter 2: Getting Around Banner.................................................................................. 8
General Menu Window ................................................................................................ 8
Menu ........................................................................................................................ 8
  My Banner ............................................................................................................ 9
  SCT Banner .......................................................................................................... 9
Help Center .............................................................................................................. 9
My Links ................................................................................................................. 10
Products: ................................................................................................................ 10
Go To... .................................................................................................................. 10
Other Navigation Tools.............................................................................................. 10
Direct Access ......................................................................................................... 10
Display Navigation Window .................................................................................... 11
Object Search ........................................................................................................ 11
Wildcard Characters............................................................................................... 12
Toolbar Buttons...................................................................................................... 12
Mouse .................................................................................................................... 12
Keyboard Equivalents ............................................................................................ 12
  Toolbar, Menu, and Keyboard Equivalent Table ................................................. 14
Banner Exit Procedures ......................................................................................... 15

Chapter 3: Forms .......................................................................................................... 16
Type of Forms ........................................................................................................... 16
Key Parts of a Form................................................................................................... 17
  Toolbar ................................................................................................................ 17
  Title Bar ............................................................................................................. 17
  Form Naming Conventions ................................................................................ 18
  Form Window .................................................................................................. 19
Other Parts of a form.............................................................................................. 20
Elements of a Form ................................................................................................... 20
  Tabs .................................................................................................................... 20
  Key Block ........................................................................................................ 21
  Blocks .............................................................................................................. 21
  Fields .............................................................................................................. 21
  Records ........................................................................................................... 22
  Iconic Buttons ................................................................................................ 22
Chapter 1: Overview

SCT Banner is Southeast’s administrative software system. This software will be used to perform your daily tasks. To be more efficient and effective, Banner INB practice is required. A practice Version 7 database has been provided. From http://sctbanas.semo.edu:9090, select the “TEST” database link. You will access the TEST database using your assigned training account and password which will be provided to you at each training session.

Purpose/Audience:

The purpose of this documentation is to provide reference material for you to use as you learn the Internet Native Banner 7 (INB 7) program. Information in this documentation is directed toward the new employee or an employee whose tasks require use of the INB software. If your position requires only the use of Banner Self-Service through the Portal, you are encouraged to attend this class for a better understanding of the entire Banner system, but attendance is not mandatory.

If you are assigned tasks using Internet Native Banner (INB), you must complete this training before you will be allowed access to INB. Attendance at the Banner Navigation & Overview training may also be required prior to participation in some other module specific training. Course descriptions, listing the intended audience and pre-requisites can be found at http://www6.semo.edu/infotech/facstaff/sctcourses.asp. Course registration can be conducted at https://www3.semo.edu/registration/homepage.asp. If in doubt, contact the Banner module leader of the training you are seeking.

Module Leaders:

<table>
<thead>
<tr>
<th>Module</th>
<th>Leader</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADMISSIONS</td>
<td>Debbie Below</td>
</tr>
<tr>
<td>ALUMNI/ADVANCEMENT</td>
<td>Brian Holdman</td>
</tr>
<tr>
<td>FINANCE</td>
<td>Sue Wilde</td>
</tr>
<tr>
<td>FINANCIAL AID</td>
<td>Karen Walker</td>
</tr>
<tr>
<td>FINANCIAL SERVICES</td>
<td>Verona Lambert</td>
</tr>
<tr>
<td>HUMAN RESOURCES</td>
<td>Misty Clifton</td>
</tr>
<tr>
<td>INFORMATION TECHNOLOGY</td>
<td>Martha Henckell, Banner Project Coordinator</td>
</tr>
<tr>
<td>STUDENT</td>
<td>Sandy Hinkle</td>
</tr>
</tbody>
</table>
Introduction:

After completing this training, you will be able to:

- Navigate through the Banner user interface
- Describe areas on the form
- Define types of forms and naming conventions
- Utilize several methods for accessing forms
- Customize Banner
- Utilize the various help functions
- Conduct various search functions

Starting Banner:

Initial start-up tips are shown below.

Display

- Installation of the J-Initiator program is required for Internet Native Banner (INB). An older version of J-Initiator was installed upon your first use of INB. With version 7, a newer version is required for PCs. During your first attempt to use Banner 7, you will be prompted to install J-Initiator. This is a one-time requirement. You must follow the instruction for this installation. Once installed, you will now be able to use Banner 7.

- Upon opening your first INB 7 session, a dialog box will appear, requiring you to install the J-Initiator plug-in. Proceed through the process by clicking on NEXT or OK as required. Immediately after installation of the J-Initiator, you will receive a security warning dialog box. Choose the GRANT ALWAYS button. This is a one-time installation. If you cancel this process, the Internet Native Banner 7 application will not run. For questions or support, please contact the IT Help Desk, ext. 4357.

- Macs will not be required to install J-Initiator but may receive a message asking if access should be granted to JAVA—select Always Grant if you receive this message.

- If you do not have a 15” monitor, scrolling may be required.

- Pop-up blockers and add-on toolbars can interfere with Banner, especially with Banner Help. Normally, pop-up blockers do not have to be removed entirely; just setting changes are necessary. If you are unfamiliar with making the setting changes, contact the IT Help Desk at x4357.

- For the best display of Banner in your browser, your monitor resolution should be set to 1024 x 768 pixels.
To set the display screen size on a PC, perform the following steps:
1. Right click on a blank area of your Windows desktop.
2. Select Properties.
3. From the Display Properties window, select the Settings tab.
4. From the Screen resolution area, slide the bar to the left or right until the setting reads 1024 x 768 pixels.
5. Select the OK button.

To set the display screen size on a Mac, perform the following steps:
1. Select the System Preferences icon on the Dock.
2. Select the Displays icon.
3. Select the desired resolution – 1024 x 768.
4. Close the System Preferences window.

Accessing INB

1. Launch your browser. Internet Explorer is the only recommendation for PC users. Mac users may use Mozilla.
2. Enter http://sctbanas.semo.edu:9090 in the URL/address box.
3. Select the TEST database for practicing tasks in Banner 7. Select the Production (PROD) database for ‘real life’ use.
4. Two Oracle windows will launch and will be represented by to tabs on your task bar. Do not close either window or your Banner session will end. The task bar tabs may appear as below:

Creating a Shortcut to Production

1. Launch your browser. Internet Explorer is the only recommendation for PC users. Mac users may use Mozilla.
2. Enter http://sctbanas.semo.edu:9090 in the URL/address box.
3. Place your mouse pointer over the link to the Production (PROD) database.
4. Right click on the link.
5. From the pop-up menu, click on Create Shortcut.
6. Right click on a blank area of your desktop.
7. From the pop-up menu, click on New>Shortcut.
8. In the dialog box, for the “Type the location of the item” textbox, paste your shortcut location by CTRL>V.
9. You will have to remove some of the information at the beginning and end of the web address just inserted. For example, you will paste an address similar to:

javascript:window.open('http://sctbanas.semo.edu:9099/forms90/f90servlet?config=TEST','",'width=1044,height=788');top.window.opener="";top.window.close();
10. Delete the text from the beginning to the ' in front of http; delete the text, beginning with the ' following the name of the database (TEST), to the end of the line. For example, delete all that has been highlighted below:

```javascript
javascript:window.open('http://sctbanas.semo.edu:9099/forms90/f90servlet?config=TEST','','width=1044,height=788');top.window.opener='';top.window.close();
```

If you are creating the shortcut for the production database, PROD will be used instead of TEST.

Login

Your login box will appear as follows:

![Login Form](image)

To login to the Production/PROD database, you will use your Southeast Key (SE Key) and password.

1. Enter your SE Key in the Username textbox. You can press the Tab key or use the mouse click to move the cursor from one field to the next.
2. Enter your SE Key password in the Password textbox.
3. Enter the Database you will be using in the Database textbox. (i.e., TEST for practice, PROD for live activities.
4. Select the Connect button or press the Enter key.

For security purposes, it is recommended that you change your password every 90 days. To change your password, go to [http://portal.semo.edu](http://portal.semo.edu). Under the My Southeast Help area, select Change my Password. In the event you should forget your password, it is highly recommended that immediately upon changing your password, you enable the Password Reset Facility (if you haven’t done so already) by going to [https://www.semo.edu/sekey/Maintain.asp](https://www.semo.edu/sekey/Maintain.asp).
Chapter 2: Getting Around Banner

In order to use the Banner Administrative System efficiently and effectively, navigation training is required.

General Menu Window

Banner 7 has provided a brand new look and functionality for the General menu.

Main Menu

Once logged into Banner 7, you will be presented with the General Menu. This menu is the starting point for navigating throughout the system. You will use the general menu to select a menu type, forms, job/processes, and QuickFlows.

The appearance of the General Menu has changed. See below:
My Banner

This personal menu contains the menus, forms, jobs/processes, or Quickflows used most frequently in the workplace. To access the links in the My Links menu, single click on the link. Use the GUAPMNU form to maintain the list as it suits your needs. See Chapter 5: Customization for set-up directions.

SCT Banner

All Banner modules are listed here.

- Select the folder to expand the menu so you can see the objects it contains.
- Continue expanding the menus until you drill down to the form, job, or Quickflow needed.
- To access the form, job or object, double click the name of the form, job, or Quickflow.
- To collapse, select the folder again.

Help Center

If you need help on any of the Banner products that Southeast has purchased, select the Help Center link.

The Help Center link can also be accessed within the Help System by clicking on the SCT Banner Help Center link.

Banner Documentation Bookshelf is also a comprehensive part of the Help Center. It includes both user and technical documentation. Before, a link to the Bookshelf was provided inside Banner. You will now access the Bookshelf directly through your Internet browser.

If this is a tool you will use, you may want to create a shortcut to the Bookshelf on your desktop. To create this shortcut, right click on a blank area of your Windows desktop; select New from the pop-up menu; select Shortcut from the drop-down menu; enter `http://sctbanas.semo.edu:9090/bdoc7x/bkshlf7x.pdf` in the Create shortcut dialog box; type Bookshelf for the name of the shortcut; select the Finish button.
Online Help is another method of getting assistance. This is a very useful tool providing help on forms and will be discussed in depth in the Toolbar section of Chapter 3: Forms.

My Links

Allows you to create links for frequently used Banner objects or external web sites. Directions for customizing the links can be found in Chapter 5: Customization.

Products:

Another method used to navigate to a particular module is the Products shortcut. All purchased Banner modules are posted in a drop down list. To go to a particular module, click and hold the down arrow button beside Products, then drag your mouse down to highlight the appropriate module. The SCT Banner menu will expand the list below the chosen module.

Go To...

The Go field in Banner 6 has been renamed GoTo… There are two ways to use this feature.

1. By typing in the 7-character name of a form, job, or Quickflow and then pressing Enter, you will be taken to the entry made.
2. Another feature is to use the up and down arrow keys to scroll through recently used objects. Once the object has been chosen, press Enter to be taken to the object.

Other Navigation Tools

New ways to access objects have been added to Banner 7.

Direct Access

The Go To… field provides direct access to a form by entering the form or object name. Another method is to use the Direct Access form GUAPARM, accessible from the File Menu.

- Select File>Direct Access.
The direct access dialog box will then open:

![Direct Access Form]

Type your form or object name in the textbox and select the Start button.

Display Navigation Window

Another method for direct access is the Direct Access Toolbar, using the F5 key:
1. While you are in a form, press the F5 key on your keyboard.
2. The Direct Access Toolbar will appear at the top of your screen just below the form title bar and above the key block. Use this toolbar as you would use the Go To… field. This toolbar has a close X button at the far right corner. It can also be closed by pressing the F5 key once opened.

**Note:** When you use either Direct Access functions from a form, the current form remains open. When you exit the requested form, process, or Quickflow, you will be returned to the original form.

Object Search

You can access a form, job, or Quickflow if you know part of its name, description or type.

**To use the object search:**
1. Double click in the Go To… box or click on the Search button.
   Or, select File>Object Search from any form.
2. Enter your search criteria on the Object Search form. You can use any of the Name, Description, or Type fields. You can also use one of the wildcard characters (see next page).
3. Select Execute Query function.
4. Scroll to the desired name.
5. Double click on the desired name.

**Note:** You will also find the Search button on forms. From this location, it will provide you with an Option List. Chapter 7: Person/Non-Persons Search will provide additional details on this feature.
**Wildcard Characters**

A wildcard is a special character that represents one or more other characters. Use wildcard symbols % and _ in the search criteria.

- % (percent sign) represents any number of missing characters
- _ (underscore) represents one occurrence of a character

Note: in the example below, ma is used. The wildcard characters can be used with any combination and in any order.

<table>
<thead>
<tr>
<th>To get these results...</th>
<th>Enter these criteria...</th>
</tr>
</thead>
<tbody>
<tr>
<td>All entries that contain ma</td>
<td>%ma%</td>
</tr>
<tr>
<td>All entries that begin with ma</td>
<td>ma%</td>
</tr>
<tr>
<td>All entries that end with ma</td>
<td>%ma</td>
</tr>
<tr>
<td>All entries that have m as a second character</td>
<td>_m%</td>
</tr>
</tbody>
</table>

**Toolbar Buttons**

At the very top of every Banner form, object, or Quickflow window, you will notice the toolbar buttons. Now it is also present on the menu window. Form loading time has decreased because regeneration or rebuilding the toolbar each time a new form is opened no longer occurs—a definite performance improvement.

Other changes include the removal of the Graph Information, Show Keys, and Banner Bookshelf buttons. The Menu, Site, and Help buttons have also been removed and are represented by links. See greater detail regarding the Toolbar in *Chapter 3: Forms*.

**Mouse**

You can use the mouse to navigate to any enterable field, record, block, or window that is currently displayed. You can access fields in any order. You can also use the mouse to click buttons.

**Keyboard Equivalents**

You can use the keyboard equivalents to access a form, window, block, or field.

*To access a form with keyboard equivalents:*
1. Read the auto hint message at the bottom of your window to determine whether a redefined function lets you navigate to another form. (Count query hits, duplicate item, duplicate record, exit with value, and list are the most commonly redefined functions).
2. If a redefined function is available, use Show Keys from the Help dropdown menu to find the keyboard equivalent for the redefined function.
To access a window or block with keyboard equivalents:
   Use Next Block and Previous Block keyboard equivalents to move among blocks.

To access a field with keyboard equivalents:
   Use the Tab key or Shift + Tab key to move between fields. If a field has an Autoskip feature, the cursor moves to the next field as soon as the required number of characters has been entered.

See the Toolbar, Menu, and Keyboard Equivalents table on next page for the keys used at Southeast.

Note: The specific list of available keys change screen to screen. The table provides a list of commonly used functions and is not complete.
# Toolbar, Menu, and Keyboard Equivalent Table

## Banner 7.x Navigation Keys

<table>
<thead>
<tr>
<th>Function</th>
<th>Icon</th>
<th>Pull Down Menu Command</th>
<th>Keystrokes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel Query: Cancels the current query.</td>
<td>![Icon]</td>
<td>Query menu then choose Cancel</td>
<td></td>
</tr>
<tr>
<td>Clear Item: Deletes information in the current field.</td>
<td>![Icon]</td>
<td>Item menu then choose Clear</td>
<td>Shift + F3</td>
</tr>
<tr>
<td>Clear Record: Clears information from the current record.</td>
<td>![Icon]</td>
<td>Record menu then choose Clear</td>
<td>Shift + F4</td>
</tr>
<tr>
<td>Count Query Hits: Displays number of records from query.</td>
<td>![Icon]</td>
<td>Query menu then choose Count Hits</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Display Error</td>
<td>![Icon]</td>
<td>Help menu then choose Display Error</td>
<td></td>
</tr>
<tr>
<td>Duplicate Record</td>
<td>![Icon]</td>
<td>Record menu then choose Duplicate</td>
<td>F5</td>
</tr>
<tr>
<td>Enter Query: Allows you to enter search criteria for a query.</td>
<td>![Icon]</td>
<td>Query menu then choose Enter</td>
<td>F7</td>
</tr>
<tr>
<td>Execute Query: Searches the database to display records based on search criteria.</td>
<td>![Icon]</td>
<td>Query menu then choose Execute</td>
<td>F8</td>
</tr>
<tr>
<td>Exit Form: Exits the current form or Banner session.</td>
<td>![Icon]</td>
<td>File menu then choose Exit</td>
<td>F4</td>
</tr>
<tr>
<td>Insert Record: Inserts record after current record.</td>
<td>![Icon]</td>
<td>Record menu then choose Insert</td>
<td></td>
</tr>
<tr>
<td>Move Between Tabs: Moves from tab to tab (blocks) in a form.</td>
<td>![Icon]</td>
<td>Ctrl + Tab</td>
<td></td>
</tr>
<tr>
<td>Next Block: Moves the cursor to the next block/tab.</td>
<td>![Icon]</td>
<td>Block menu then choose Next</td>
<td>Page Down</td>
</tr>
<tr>
<td>Next Field: Moves cursor to next field</td>
<td>![Icon]</td>
<td>Record menu then choose Next</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Next Record: Moves the cursor to the first entry field of the next record.</td>
<td>![Icon]</td>
<td>Down Arrow</td>
<td></td>
</tr>
<tr>
<td>Online Help: Opens online help system.</td>
<td>![Icon]</td>
<td>Help menu then choose Online Help</td>
<td>F1</td>
</tr>
<tr>
<td>Previous Block: Moves the cursor to the previous block/tab.</td>
<td>![Icon]</td>
<td>Block menu then choose Previous</td>
<td>Page Up</td>
</tr>
<tr>
<td>Previous Field: Moves cursor to previous field.</td>
<td>![Icon]</td>
<td>Record menu then choose Previous</td>
<td>Tab + Shift</td>
</tr>
<tr>
<td>Previous Record: Moves the cursor to the first entry field of previous record.</td>
<td>![Icon]</td>
<td>Record menu then choose Previous</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Print: Captures the current window and sends to printer.</td>
<td>![Icon]</td>
<td>File menu then choose Print</td>
<td>Shift + F8</td>
</tr>
<tr>
<td>Remove Record: Removes the current record.</td>
<td>![Icon]</td>
<td>Record menu then choose Remove</td>
<td></td>
</tr>
<tr>
<td>Rollback: Clears all information and returns you to the first entry field.</td>
<td>![Icon]</td>
<td>File menu then choose Rollback</td>
<td>F3</td>
</tr>
<tr>
<td>Save: Saves all changes entered.</td>
<td>![Icon]</td>
<td>File menu then choose Save</td>
<td>F10</td>
</tr>
<tr>
<td>Select: Selects a record after a query is executed.</td>
<td>![Icon]</td>
<td>File menu then choose Select</td>
<td>F9</td>
</tr>
<tr>
<td>Show Keys: Shows available keyboard commands.</td>
<td>![Icon]</td>
<td>Help menu then choose Show Keys</td>
<td>Ctrl + F1</td>
</tr>
<tr>
<td>View and Send Message: View system or user messages.</td>
<td>![Icon]</td>
<td>Help menu then choose View and Send Message</td>
<td></td>
</tr>
</tbody>
</table>
Banner Exit Procedures:

To exit or close a form, object, or Quickflow:
1. Click on the X in the right corner of the form title bar
   Or
2. Type EXIT in the Go To… textbox and press enter.

To exit the Banner session:
1. Type EXIT in the Go To… textbox and press enter
   Or
2. Click File>Exit from the dropdown menu.
   Or
3. Return to the Main Menu and click the X button.
Chapter 3: Forms

A form is an online document that you can enter or look up information in your database. There are numerous types of forms, each used for a different purpose. Module leaders utilize all types, but as an end user, you will have access to only the types of forms needed to perform your tasks.

Type of Forms

There are many types of forms. Some forms are for all end users, while some are used only by module application builders.

Types of forms include:

- **Application**—Used to enter, update, and query information. This is the most common form used. (All end users)
- **Query**—Used to look up existing information, often returning information to the calling form. You must access the query form from another form. (All end users)
- **Inquiry**—Used to look up existing information, often returning information to the calling form. You can access this form from the main menu, another form, Direct Access, or Object Search. (All end users)
- **Validation**—Used to define values that can be entered in specific fields on application forms. (Module use only)
- **Rule**—Used to tailor Banner to Southeast’s procedural requirements. (Module use only)
- **Control**—Used to define processing rules. (Module use only)
- **Wizard**—Used to provide step-by-step instructions for completing an application form. (All end users)
Key Parts of a Form

To navigate efficiently around a form, it is essential to understand the key parts of a form.

Toolbar

The Banner toolbar contains buttons that perform common functions. It is located directly under the menu bar.

To access a toolbar function, click the appropriate icon button. You can click a button any time, except when you are in the midst of working with a dialog box, alert box, or List of Values (LOV). If a button is dimmed, it is disabled and is not available at that particular time.

Note: When you move your cursor over a button and pause for a second, a tip appears in a textbox, identifying the name of the button.

Title Bar

The title bar shows the following information:
- Descriptive form name
- Form name
- Banner version
- Banner database
- Minimize or Exit buttons
Form Naming Conventions

Every form has an abbreviated seven character from name. Each position in the form name serves a purpose.

**Position 1:** identifies the Banner product or module owning the form, report, process or table. An abbreviated table is shown below.

<table>
<thead>
<tr>
<th>CODE</th>
<th>PRODUCT/MODULE</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Advancement</td>
</tr>
<tr>
<td>F</td>
<td>Finance</td>
</tr>
<tr>
<td>G</td>
<td>General</td>
</tr>
<tr>
<td>N</td>
<td>Position Control</td>
</tr>
<tr>
<td>P</td>
<td>Payroll</td>
</tr>
<tr>
<td>R</td>
<td>Financial Aid</td>
</tr>
<tr>
<td>S</td>
<td>Student (shared)</td>
</tr>
<tr>
<td>T</td>
<td>Accounts Receivable</td>
</tr>
</tbody>
</table>

**Position 2:** the code represents a different purpose for each product/module. To view the complete table displaying these code by module, visit [http://www6.semo.edu/infotech](http://www6.semo.edu/infotech) and click on Admin Sys>/SCT End User>Cheat Sheets>Naming Conventions.

**Position 3:** identifies the type of form, report, process, or table.

<table>
<thead>
<tr>
<th>CODE</th>
<th>PRODUCT/MODULE</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Application</td>
</tr>
<tr>
<td>B</td>
<td>Base Table</td>
</tr>
<tr>
<td>I</td>
<td>Inquiry</td>
</tr>
<tr>
<td>P</td>
<td>Process</td>
</tr>
<tr>
<td>R</td>
<td>Rule Table, Repeating Table, Report, or Process</td>
</tr>
<tr>
<td>V</td>
<td>Validation</td>
</tr>
<tr>
<td>M</td>
<td>Maintenance</td>
</tr>
</tbody>
</table>

**Positions 4, 5, 6, 7:** identifies a unique four-character code for the form, report, process, or table. The following are some examples of four-character names.

<table>
<thead>
<tr>
<th>CODE</th>
<th>PRODUCT/MODULE</th>
</tr>
</thead>
<tbody>
<tr>
<td>***IDEN</td>
<td>Identification</td>
</tr>
<tr>
<td>***PINC</td>
<td>Position Incumbent</td>
</tr>
<tr>
<td>***STDN</td>
<td>Student Relation</td>
</tr>
<tr>
<td>***PERS</td>
<td>Person</td>
</tr>
<tr>
<td>PART</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Title</td>
<td>May display the form’s descriptive name, the seven-character ID name, the software version number and the database name.</td>
</tr>
<tr>
<td>Search Icon</td>
<td>Calls up the set-up form that contains the pre-entered data for you to select.</td>
</tr>
<tr>
<td>Key Block</td>
<td>Contains information that determines what is entered or displayed on the remainder of the form.</td>
</tr>
<tr>
<td>Information Block</td>
<td>Displays data about the information entered in the Key Block. Area where you enter information prior to updating a record.</td>
</tr>
<tr>
<td>Field</td>
<td>Area on a form where you can enter, query, change, and display specific information.</td>
</tr>
<tr>
<td>Pull-down List</td>
<td>Used to select a field value from a list of pre-defined values. A down arrow in the right side of the field indicates that the field has a pull down list.</td>
</tr>
<tr>
<td>Tabs</td>
<td>Tabs are used to arrange information in a meaningful way, and allow you to navigate easily between groups or blocks of information.</td>
</tr>
</tbody>
</table>
Other Parts of a form:

Radio buttons

Checkbox

PART DESCRIPTION

Radio Button Used to select on of several options. Only one radio button can be selected at a time.

Checkbox Used to enable or disable features or options.

Elements of a Form

Each element on a form has a specific purpose. Understanding these elements will aid in navigating Banner forms.

Tabs

Certain forms feature a tabbed interface. Tabs are used to arrange information in a meaningful way and allow you to navigate both easily and quickly between blocks or groups of information.

Tab Functionality:

- Click on the tab to access information rather than performing a Next Block function. On forms that do not display tabs, the Next Block function will be used.
- When you click on a tab, it may open an entirely different form (from SPAIDEN, click on E-mail and GOAEMAL will open inside the SPAIDEN form window).
To navigate between tabs:

- Click on the Tab or press F2 to retrieve a list of the tabs available from the current window and click on the tab or press the Next Block button.

Key Block

The first block on most forms (except validation, list, and other module type forms) contains key information. This is referred to as the key block. The key block determines what is entered or displayed on the rest of the form.

Blocks

A block is a section on a form that contains related information. If a form has more than one block, each block (except the key block) may be enclosed in a beveled box.

Most blocks have a title. Exceptions are:

- Key blocks
- If the form has only one block
- If the form has only the key block and one other block

To navigate between fields

- Ctrl + Tab will move you forward one tab.
- Shift + Tab will move you backward one tab.

Fields

Fields are labeled space within a block. You can enter, query, change and/or display specific information within a field.

- There is usually more than one field on a form.
- Two field states can be presented on a form.
  - Enable
    - Cursor is allowed in the field
    - Information in the field is displayed in black text
• Disabled
  ▪ Cursor is not allowed in the field
  ▪ If information exists, it cannot be changed

• Any data that is entered or displayed in a field is a value. There are two types of values.
  o Free-format: Free access to type in whatever information is required. Example—Street address
  o List of Values (LOV): Data comes from previously defined values and is provides a list of choices to select from. To see the LOV, double click in a LOV field, press F9, or use the Search button. Example—State abbreviations

**LOV:**

<table>
<thead>
<tr>
<th>Citizenship:</th>
<th>Citizen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marital Status:</td>
<td>Single</td>
</tr>
</tbody>
</table>

**Navigating Fields**

To navigate between fields:
  - Next field: Use Tab or Enter
  - Previous field: Use Shift + Tab

**Records**

A record is a group of fields that make up a logical unit. There may be more than one record in a block.

Example: A person record is made up of several fields: ID, Last Name, First Name, Middle Name, Birth Date, Change Indicator, and Type (i.e. SOAIDEN form).

To navigate to different records, you can choose one of three ways:
  1. Use the Next Record/Previous Record toolbar buttons
  2. Use the Record drop down menu
  3. Use the Down/Up arrow keys

**Iconic Buttons**

Iconic buttons are small squares that contain an icon (picture). They represent one or more actions that can be performed for the associated field or record.
While your tasks or procedures may not use a form that has Iconic buttons, all buttons are shown below:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td>Displays another form or window where you can search for information.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Displays a calendar for you to choose a date.</td>
</tr>
<tr>
<td>Data</td>
<td>Indicates that data is available for the field.</td>
</tr>
<tr>
<td>No Data</td>
<td>Indicates that no data is available for the field.</td>
</tr>
<tr>
<td>Details</td>
<td>Displays details for the record.</td>
</tr>
<tr>
<td>In Process</td>
<td>Indicates the process has started but is not complete.</td>
</tr>
<tr>
<td>Complete</td>
<td>Indicates the process is complete.</td>
</tr>
<tr>
<td>Maintenance</td>
<td>Updates information in the database.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the current record or records.</td>
</tr>
<tr>
<td>Comments</td>
<td>Displays a window where you can enter text for the record.</td>
</tr>
<tr>
<td>Calculate</td>
<td>Performs a calculation on the data in the field.</td>
</tr>
<tr>
<td>Approve</td>
<td>Indicates process is approved.</td>
</tr>
<tr>
<td>Disapprove</td>
<td>Indicates process is not approved.</td>
</tr>
<tr>
<td>Generate ID</td>
<td>Generates a new ID.</td>
</tr>
</tbody>
</table>
Form Features

Banner 7 is now utilizing the pop-up menu. In addition, easier use of the calendar and calculator has been included with the version changes.

Option Menu

Another new functionality in the form view is a pop-up option menu. By right-clicking on a blank area of the form, the option menu will open. You will now have quick access to the following functions:

- Rollback
- Save
- Exit form
- Print
- Add the form to your Personal Menu (You will need to exit Banner and then return to see changes)
- All tabs available from that particular form

Street Line 1: INFORM TECHN STUDENT LABS
Street Line 2: 
Street Line 3: 
City: CAPE GIRARDEAU
State or Province: MO - Missouri
ZIP or Postal Code: 63701
County: M0031 - Cape Girardeau
Nation: 
Telephone Type: EE - Dept Address f/ SE Employee:
Telephone: 

[Diagram of Options Menu with Rollback, Save, Exit, Print, Add to Personal Menu, Current Identification, Alternate Identification, Address, Telephone, Biographical, E-mail, Emergency Contact, System Data Summary [GUASYST]]
Using the Calculator

There are three ways to access the calculator:
- Double click any numeric field, or click the calculator button.
- Use Direct Access to display the calculator form (GUACALC). When accessed this way, you cannot select a date and return it to a form field.
- Select Help>Calculator. When accessed this way, you cannot return a calculation to a form field.

Using the Calendar

Double click any date on the calendar to return it to the date field on the form.

There are three ways to access the calendar:
- Double click in the date field or click the calendar button.
- Use Direct Access to display the calendar form (GUACALN) When accessed this way, you cannot select a date and return it to a form field.
- Select Help>Calendar. When accessed this way, you cannot select a date and return it to a form field.
Chapter 4: Features

Banner Online Help is one of the added feature favorites to version 7. Other great features include Common Matching, which will aid in the prevention of duplicate records, and Fine-grained access.

New Banner Online Help

Banner 7 features a new online help system that contains information about forms and fields, as well as tasks you can perform with Banner. This help system runs in a web browser and is available by selecting the:

- Online Help button on the toolbar
- Online Help option from the Help dropdown menu
- Help Center link on the main menu
Tips for Using Online Help

- **Accessing Online Help from a Form**
  With a form open, information regarding the current form is displayed.

- **Browsing for Topics**
  The contents tab and the breadcrumb trail both enable you to browse for topics categorically. Form and field information is organized by Banner module. Task information is contained under the Procedures heading.
• Searching for Topics
The Search tab allows you to search for topics within the help system. You can also use your Internet browser’s “search on page” feature to find specific text on a help page.

• Using the Index
The Index tab provides an alphabetical listing of topics within the help system. When you enter the letters of a term, the index will scroll through the topics to the closest alphabetical match.

• Using the Field Link
Many form description are quite long so you will sometimes find a link that goes to field descriptions that open in a separate window.
Additional New Features

Some of the new, miscellaneous features are listed below.

- Banner 7 now uses Verdana Font
- Forms now have equal left and right margins.
- Fine-grained access control security is available and may be used to prevent access to certain fields on certain forms that you may have had access to previously.
- When the Search button brings up the Option list, you can now use your keyboard to navigate the various options. Use the arrow keys on your keyboard to select the option; press Enter to access the option.
Chapter 5: Customization

Have Banner your way. With customization, you can make Banner more personalized.

My Banner

There are several different methods to customize your personal menu with the objects that you frequently use.

Note: It is recommended that you add only one object at a time and save after each addition. This way, you will be able to detect a problem right away, without having to delete each new addition.

To use the My Banner Maintenance form (GUAPMNU-see figure below)
1. Open the GUAPMNU form.
2. Use the Type: dropdown list from the left pane to select the object type.

   Note: You can query to reduce the object list. See instructions below.

3. In the left pane, select each object you want to add to the menu by double clicking it. When you select an object, it becomes highlighted.

   Note: Multiple selections, as well as multiple object types can be selected and inserted at one time.

4. Click the right pane in the field location you would want the selections placed. The inserted items will push down all listed objects below the cursor.
5. Click the Insert Selection button in the middle of the form. The selected objects are added to the right pane.
6. Changing the description is optional.
7. Save
To query Object List:
Use these steps to reduce the number of objects in the left pane.

1. In GUAPMNU, select the object for the query in the Type of Object dropdown list.
2. Place your cursor in the left pane in an Object field.
3. Select the Enter Query function. You can use wildcard characters.

To add an object to My Banner if you know the object’s name:
1. Open the GUAPMNU form.
2. Place your cursor in a blank right pane field.
3. Enter the object’s name.
4. Press Enter and save changes.

To add an object while in the form:
From a form that you have modify rights (this will be grayed out/not available if you have only query rights on the form), follow these steps:
1. Right click in a blank area of the form.
2. In the pop-up menu, select Add to Personal Menu.
3. The form will not appear in the My Banner menu until you have exited the Banner session.

To delete an object from the My Banner menu:
1. Open the GUAPMNU form.
2. In the right pane, select each object to be deleted by double clicking the object.
3. Click the Remove button in the middle of the form.
4. Save.

My Links

To access the links in the My Links menu, single click on the link. To add/personalize the hyperlinks or object links in the My Links portion of the General Menu, there are two methods: from the dropdown menu (available from the General menu or any object) and the GUAUPRF form.

From the dropdown menu:
1. Click File>Preferences
2. See #3 below.

From the General Users Maintenance Form:
1. Enter GUAUPRF in the Go To... textbox field.
2. See #3 below.

To add or change Personal Links:
3. Click on the My Links tab.
4. For each link, there are two associated Description/Default Value/User Value sections. The first one allows you to create and enter a personal link description. In the User Value textbox, enter a “friendly” name for your link, i.e., Information Technology for the IT web site or General Student for the SGASTDN form.

5. In the second associated section, enter the Internet address (include http://) or the object name.
It is NOT recommended that changes be made to Display Options or Directory Options.

My Links Tab

Two associated link sections. Both User Values must be completed.
Chapter 6: Tips and Tricks

There are many time saving steps that can be taken. A few are listed below.

Dates
- In most date fields, enter a T for today’s date and press Enter or Tab.
- By entering two digits in a date field, Banner assumes the current month and year.
- By entering four digits in a date field, Banner assumes the current year. For example: 0315 would result in 15-Mar-2006 entry.

Go To…field from any location
- Enter EXIT to exit the current form/object
- Press the up or down arrow keys to navigate to any of the last 10 forms you accessed.

Go To…field from main menu
- Enter *PERSONAL to open the My Banner menu
- Enter EXIT to exit your Banner session.
- Enter the menu name to expand that menu. Example: *STUDENT
Chapter 7: Person/Non-Person Searches

Whether conducting a person or non-person search, the process is the same, just different forms are used. SPAIDEN is used for person searches, while SOACOMP is used for non-person searches.

Searching for a Person using an ID or Last Name and/or First Name:
1. Open the SPAIDEN form and click on the Search button. Tips: The Search option is available on other forms besides SPAIDEN. If you would like to go directly to the Search form, you can type SOAIDEN in the Direct Access field.
2. Select Person Search. (Vendors are considered non-persons)
3. From the SOAIDEN form, enter any information that will aid in your query. Tips: If you do not receive a return of information, reduce the amount of information provided. Wildcard character(s) should be used if correct spelling is unknown or no return of information occurs.
4. Press the F8 key or press the Execute Query button.

If additional information is needed to verify you have the correct person (i.e., person is currently a student, whether he/she was ever a Southeast student, person’s address, etc.):
1. Select the record.
2. Right click on a blank area of the form to retrieve the Options menu.
3. Click on Search and Display More Detail (SOAIDNS).
4. In the SOAIDNS form, you will need to conduct a query once again. Press the F8 key or press the Execute Query button.

See SOAIDNS form on next page.
If your goal is to use this record in SPAIDEN:
1. Close SOAIDNS and return to SOAIDEN
2. Select the correct record by clicking the Select button or double clicking the record.
3. Your record will now be placed in SPAIDEN.

Searching Using the Sounds Like Option:
1. Go to the SOAIDEN form.
2. Click on the Exit button to stop the Query mode.
3. Right click on a blank area of the form to retrieve the Options menu.
4. Select the Search Using Sounds Like.
5. Enter a phonetic spelling. Tips: If you do not receive a return of information, reduce the amount of information provided—such as use last name only. If you receive too much information, try adding the first name and last name.
6. Press the F8 key or press the Execute Query button.